DNF游戏CALL之全局力量丶全局智力(易语言写法)

DNF游戏CALL之全局力量丶全局智力(易语言写法)

今天小编为大家带来一个比较烂大街的游戏功能 写法,大神勿喷,入门基础者可以试试效果。
首先要写一个游戏的功能,咱们必须要获取到游戏的进程ID,然后进行内存的读取和写入。
咱们可以用精易模块的命令来获取,(模块的下载链接在文章底部)

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

.版本 2

.子程序 进程ID获取
.局部变量 游戏进程ID, 整数型

进程ID = 取进程ID (“DNF.exe”)

.版本 2

.子程序 独家伤害
.局部变量 开关, 逻辑型, 静态
.局部变量 智力, 整数型
.局部变量 力量, 整数型

.判断开始 (开关 = 假)
开关 = 真
智力 = 99999
力量 = 99999
写内存字节集 (进程ID, #全局智力, { 184 } + 到字节集 (智力) + { 195 }, 6)
写内存字节集 (进程ID, #全局力量, { 184 } + 到字节集 (力量) + { 195 }, 6)

‘ XT公告 (“独家伤害 – 开启”)
.默认
开关 = 假
写内存字节集 (进程ID, #全局智力, { 85, 139, 236, 131, 236, 20 }, 6)
写内存字节集 (进程ID, #全局力量, { 85, 139, 236, 131, 236, 20 }, 6)
‘ XT公告 (“独家伤害 – 关闭”)
.判断结束

精易模块下载点我

 

更多精彩功能写法,尽在游戏逆向网  www.uxnx.cn

 

 

常见问题FAQ

免费下载或者VIP会员专享资源能否直接商用?
本站所有资源版权均属于原作者所有,这里所提供资源均只能用于参考学习用,请勿直接商用。若由于商用引起版权纠纷,一切责任均由使用者承担。更多说明请参考 VIP介绍。

发表评论

欢迎访问本站
您的访问时本站的荣幸
希望您能在本站
找到您想要的资源