DNF游戏CALL之变身大眼怪丶变身团长蔡依林(易语言写法)

今天小编为大家带来一个比较烂大街的游戏功能 写法,大神勿喷,入门基础者可以试试效果。
首先要写一个游戏的功能,咱们必须要获取到游戏的进程ID,然后进行内存的读取和写入。
咱们可以用精易模块的命令来获取,(模块的下载链接在文章底部)

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

.版本 2

.子程序 进程ID获取
.局部变量 游戏进程ID, 整数型

进程ID = 取进程ID (“DNF.exe”)

.版本 2

.子程序 图纸怪物
.参数 召唤代码, 整数型
.局部变量 召唤结构, 整数型, , , 4
.局部变量 触发指针, 整数型, , , 8
.局部变量 召唤地址, 整数型, 静态, , c
.局部变量 召唤参数, 整数型, , , 10
.局部变量 CALL地址, 整数型, , , 14

.如果真 (召唤地址 = 0)
召唤地址 = 十六到十 (“400800”)

.如果真结束
‘ 召唤地址 = 十六到十 (“400600”)
CALL地址 = #怪物CALL
触发指针 = 读内存整数型 (进程ID, #人物基址)
召唤参数 = 读内存整数型 (进程ID, #召唤参数)
写内存整数型 (进程ID, 召唤地址, 召唤代码)
写内存整数型 (进程ID, 召唤地址 + 4, 85)
写内存整数型 (进程ID, 召唤地址 + 8, 85)
写内存整数型 (进程ID, 召唤地址 + 12, 120000)
写内存整数型 (进程ID, 召唤地址 + 16, 1)
置汇编代码 ({ })
‘ Pushad ()
Push (召唤地址)
Push (触发指针)
Mov_ECX (召唤参数)
Mov_EAX (CALL地址)
Call_EAX ()
‘ Popad ()
‘ ret ()
内存汇编 (取汇编代码 ())
清空汇编代码 ()

.子程序 大眼怪

大眼怪 = 取反 (大眼怪)
.如果 (大眼怪 = 真)
‘ Xr1 (“大眼怪 – 开启”)

图纸怪物 (107000902)
超级延时 (2000)
.否则
‘ Xr1 (“大眼怪 – 关闭”)
.如果结束

 

精易模块下载点我

 

更多精彩功能写法,尽在游戏逆向网  www.uxnx.cn

常见问题FAQ

免费下载或者VIP会员专享资源能否直接商用?
本站所有资源版权均属于原作者所有,这里所提供资源均只能用于参考学习用,请勿直接商用。若由于商用引起版权纠纷,一切责任均由使用者承担。更多说明请参考 VIP介绍。

发表评论

欢迎访问本站
您的访问时本站的荣幸
希望您能在本站
找到您想要的资源