DNF游戏CALL之全屏攻击(易语言写法)

DNF游戏CALL之全屏攻击(易语言写法)

今天小编为大家带来一个比较烂大街的游戏功能 写法,大神勿喷,入门基础者可以试试效果。
首先要写一个游戏的功能,咱们必须要获取到游戏的进程ID,然后进行内存的读取和写入。
咱们可以用精易模块的命令来获取,(模块的下载链接在文章底部)

.版本 2

.子程序 进程ID获取
.局部变量 游戏进程ID, 整数型

进程ID = 取进程ID (“DNF.exe”)

.版本 2

.子程序 全屏攻击
.局部变量 钩子地址1, 整数型
.局部变量 钩子地址2, 整数型
.局部变量 钩子地址3, 整数型
.局部变量 钩子地址4, 整数型
.局部变量 钩子开关, 逻辑型, 静态
.局部变量 钩子地址1原值, 字节集, 静态
.局部变量 钩子地址2原值, 字节集, 静态
.局部变量 钩子地址3原值, 字节集, 静态
.局部变量 钩子地址4原值, 字节集, 静态

钩子地址1 = #攻击范围
钩子地址2 = #范围写入
钩子地址3 = #伤害范围
钩子地址4 = #范围写出
钩子地址1原值 = 读内存字节集 (进程ID, 钩子地址1, 6)
钩子地址2原值 = 读内存字节集 (进程ID, 钩子地址2, 6)
钩子地址3原值 = 读内存字节集 (进程ID, 钩子地址3, 6)
钩子地址4原值 = 读内存字节集 (进程ID, 钩子地址4, 6)
写内存字节集 (进程ID, 钩子地址1, { 144, 144, 144, 144, 144, 144 }, )
写内存字节集 (进程ID, 钩子地址2, { 144, 144, 144, 144, 144, 144 }, )
写内存字节集 (进程ID, 钩子地址3, { 144, 144, 144, 144, 144, 144 }, )
写内存字节集 (进程ID, 钩子地址4, { 144, 144, 144, 144, 144, 144 }, )

 

精易模块下载点我

常见问题FAQ

免费下载或者VIP会员专享资源能否直接商用?
本站所有资源版权均属于原作者所有,这里所提供资源均只能用于参考学习用,请勿直接商用。若由于商用引起版权纠纷,一切责任均由使用者承担。更多说明请参考 VIP介绍。

发表评论

欢迎访问本站
您的访问时本站的荣幸
希望您能在本站
找到您想要的资源